diff configure.in @ 7887:627b10572d82

configure.in: fix invalid placement of variables restoration statements
author Jaroslav Hajek <highegg@gmail.com>
date Wed, 11 Jun 2008 09:51:35 +0200
parents e3a502930e2a
children bcacdcc726f7
line wrap: on
line diff
--- a/configure.in
+++ b/configure.in
@@ -666,10 +666,11 @@
           AC_DEFINE(HAVE_FTGL, 1, [Define to 1 if FTGL is present])
 	  AC_MSG_RESULT(yes)
 	  XTRA_CXXFLAGS="$XTRA_CXXFLAGS $FT2_CFLAGS"],[
-	  AC_MSG_RESULT(no)])],[
+	  AC_MSG_RESULT(no)])
+	LIBS="$save_LIBS"
+	CXXFLAGS="$save_CXXFLAGS"
+	],[
           warn_graphics="FTGL library not found. Native renderer will not have on-screen text"])
-	  LIBS="$save_LIBS"
-	  CXXFLAGS="$save_CXXFLAGS"
     AC_LANG_POP(C++)
   fi
 fi