log

age author description
Sat, 15 May 2010 17:45:24 +0000 translators (svn r19825) -Update from WebTranslator v3.0: draft
Sat, 15 May 2010 14:37:33 +0000 rubidium (svn r19824) -Fix [FS#3837] (19799): aircraft would be heading to someone draft
Sat, 15 May 2010 08:44:10 +0000 alberth (svn r19823) -Fix: Ensure that both texts of the newgrf gui download button fit. draft
Fri, 14 May 2010 20:29:26 +0000 glx (svn r19822) -Fix (r19814): missing semicolon draft
Fri, 14 May 2010 17:49:55 +0000 alberth (svn r19821) -Fix (r19816): Minimap displayed a black screen instead of the upper edge of the map (reported by IPG). draft
Fri, 14 May 2010 17:45:38 +0000 translators (svn r19820) -Update from WebTranslator v3.0: draft
Thu, 13 May 2010 17:45:44 +0000 translators (svn r19819) -Update from WebTranslator v3.0: draft
Thu, 13 May 2010 16:00:50 +0000 smatz (svn r19818) -Fix [FS#3784](r16004): kicking clients by IP didn't work draft
Thu, 13 May 2010 12:42:56 +0000 rubidium (svn r19817) -Fix: MSVC compile warnings draft
Thu, 13 May 2010 11:19:30 +0000 rubidium (svn r19816) -Codechange: use static const uint for the unnamed 'tile consts' enum as well draft
Thu, 13 May 2010 11:07:04 +0000 smatz (svn r19815) -Cleanup: remove two unused variables draft
Thu, 13 May 2010 10:14:29 +0000 rubidium (svn r19814) -Codechange: give some more unnamed enums a name, in case they consisted of unrelated values use static const (u)int draft
Thu, 13 May 2010 10:00:51 +0000 rubidium (svn r19813) -Fix (r19807): initialising viewports kinda failed draft
Thu, 13 May 2010 09:44:44 +0000 rubidium (svn r19812) -Codechange: give some unnamed enums a name or, in case they consisted of unrelated values use static const (u)int draft
Thu, 13 May 2010 09:12:52 +0000 rubidium (svn r19811) -Codechange: make the last bits from table/strings.h use static consts too instead of an unnamed enum draft
Thu, 13 May 2010 09:11:27 +0000 rubidium (svn r19810) -Fix: [YAPF] Improperly formatted (global) constant draft
Thu, 13 May 2010 09:04:41 +0000 rubidium (svn r19809) -Codechange: make some unnamed network related enums/defines static const variables draft
Thu, 13 May 2010 08:59:50 +0000 rubidium (svn r19808) -Codechange: NetworkCalculateLag returned an uint, so keep it that way draft
Thu, 13 May 2010 08:56:01 +0000 rubidium (svn r19807) -Codechange: instead of having an unnamed enum and passing it as an int, name the enum and pass that draft
Thu, 13 May 2010 05:34:21 +0000 smatz (svn r19806) -Codechange: silence one warning draft
Thu, 13 May 2010 05:29:25 +0000 smatz (svn r19805) -Codechange: disable warnings about unused but set variables when building with asserts disabled draft
Wed, 12 May 2010 21:39:56 +0000 rubidium (svn r19804) -Fix (r19802): Compile before commit, or at least triple check :) draft
Wed, 12 May 2010 21:07:31 +0000 belugas (svn r19803) -Fix(r19802): Compile before commit, or at least double check... draft
Wed, 12 May 2010 20:59:39 +0000 belugas (svn r19802) -Codechange: Replace some more magic numbers by corresponding constants draft
Wed, 12 May 2010 20:50:10 +0000 rubidium (svn r19801) -Add [FS#3691]: custom naming of depots. Based on work by sbr draft
Wed, 12 May 2010 20:02:46 +0000 belugas (svn r19800) -Codechange: Replace magic number by corresponding constant draft
Wed, 12 May 2010 19:21:00 +0000 rubidium (svn r19799) -Change: give depots an unique name in the same manner buoys and waypoints are named draft
Wed, 12 May 2010 18:31:39 +0000 rubidium (svn r19798) -Codechange: generalise the waypoint naming method draft
Wed, 12 May 2010 18:20:53 +0000 rubidium (svn r19797) -Cleanup: language files due to r19796 draft
Wed, 12 May 2010 18:19:36 +0000 rubidium (svn r19796) -Codechange: introduce and use a {DEPOT} string command draft
Wed, 12 May 2010 17:45:13 +0000 translators (svn r19795) -Update from WebTranslator v3.0: draft
Wed, 12 May 2010 13:15:36 +0000 rubidium (svn r19794) -Fix: missing header in MSVC project files draft
Wed, 12 May 2010 13:14:56 +0000 rubidium (svn r19793) -Add [FS#3657]: source.list to the Visual Studio solutions and run the project file regeneration when source.list changes (adf88) draft
Tue, 11 May 2010 21:02:26 +0000 rubidium (svn r19792) -Change: use the typed FOR_EACH_SET_BIT for Tracks (adf88) draft
Tue, 11 May 2010 21:01:57 +0000 rubidium (svn r19791) -Change: use the typed FOR_EACH_SET_BIT for RoadTypes (adf88) draft
Tue, 11 May 2010 21:01:01 +0000 rubidium (svn r19790) -Change: use the typed FOR_EACH_SET_BIT for CargoIDs (adf88) draft
Tue, 11 May 2010 20:59:54 +0000 rubidium (svn r19789) -Add [FS#3519]: a typed FOR_EACH_SET_BIT (adf88) draft
Tue, 11 May 2010 20:48:06 +0000 rubidium (svn r19788) -Codechange: make FOR_EACH_SET_BIT not change the value of the passed bit variable, i.e. allow expressions as parameter draft
Tue, 11 May 2010 20:44:58 +0000 glx (svn r19787) -Fix: compilation with MinGW GCC 4.5.0 and UNICODE draft
Tue, 11 May 2010 17:45:15 +0000 translators (svn r19786) -Update from WebTranslator v3.0: draft
Tue, 11 May 2010 14:16:16 +0000 rubidium (svn r19785) -Codechange: reorder/rework the checks for CheckNextTrainTile a bit, causing the whole function to be a few percent faster and hopefully better to understand draft
Tue, 11 May 2010 11:55:12 +0000 rubidium (svn r19784) -Fix [FS#3770]: if a waypoint is immediately followed by a path signal a reservation would be made from that path signal before the waypoint is marked passed. As a result the order to go to the waypoint is used to reserve the path after the waypoint and as such trains get lost draft
Mon, 10 May 2010 17:45:10 +0000 translators (svn r19783) -Update from WebTranslator v3.0: draft
Mon, 10 May 2010 17:27:34 +0000 peter1138 (svn r19782) -Fix [FS#3828]: NULL pointer deference when testing relative scope *action2 on an unbuilt engine. draft
Mon, 10 May 2010 17:11:24 +0000 rubidium (svn r19781) -Fix [FS#3809]: compilation on NetBSD failed (Krille) draft
Mon, 10 May 2010 09:50:49 +0000 rubidium (svn r19780) -Fix [FS#3807]: make sure that when checking whether a path + filename are valid the whole string can be constructed within an array of length MAX_PATH. If not, the name is too long and is deemed invalid draft
Mon, 10 May 2010 09:49:02 +0000 rubidium (svn r19779) -Change: add a return type to AppendPathSeparator and use that to determine whether we could append the path separator. If not, do not recurse into that directory as the path would exceed the maximum path length draft
Mon, 10 May 2010 09:43:49 +0000 rubidium (svn r19778) -Change: use the value from PATH_MAX (POSIX) for MAX_PATH (Windows/OpenTTD) if it exists draft
Mon, 10 May 2010 09:37:17 +0000 rubidium (svn r19777) -Change: use the file scanner to find the .tars draft
Mon, 10 May 2010 09:35:25 +0000 rubidium (svn r19776) -Change: don't scan for tars in the script scanner; it has already happened. draft
Sun, 09 May 2010 18:13:36 +0000 smatz (svn r19775) -Fix: improper use of 'then' in few comments (ln) draft
Sun, 09 May 2010 17:45:22 +0000 translators (svn r19774) -Update from WebTranslator v3.0: draft
Sun, 09 May 2010 15:59:30 +0000 yexo (svn r19773) -Add: [NoAI] AIIndustry::GetIndustryID(TileIndex) draft
Sun, 09 May 2010 15:17:09 +0000 yexo (svn r19772) -Fix [FS#3818]: the break-on-log-message feature could trigger an assert (Zuu) draft
Sat, 08 May 2010 17:45:19 +0000 translators (svn r19771) -Update from WebTranslator v3.0: draft
Sat, 08 May 2010 17:33:04 +0000 frosch (svn r19770) -Feature: Hide all other industries when ctrl+clicking an industry type in smallmap legend. draft
Sat, 08 May 2010 14:43:59 +0000 frosch (svn r19769) -Fix [FS#3820]: MV_VOID tiles shall have no tropic zone. draft
Sat, 08 May 2010 14:36:56 +0000 smatz (svn r19768) -Fix: half-desert tiles would never revert back to clear tiles draft
Fri, 07 May 2010 20:39:00 +0000 alberth (svn r19767) -Fix [FS#3808]: Height in smallmap was different from measured heights (ChillCore). draft
Fri, 07 May 2010 20:27:22 +0000 alberth (svn r19766) -Codechange: Store tile height of smallmap contour legend in the LegendAndColour struct. draft