diff configure.in @ 702:45764610984a

[project @ 1994-09-15 02:32:47 by jwe]
author jwe
date Thu, 15 Sep 1994 02:32:47 +0000
parents 4e67ff861c84
children 164e497d6039
line wrap: on
line diff
--- a/configure.in
+++ b/configure.in
@@ -21,7 +21,7 @@
 dnl along with Octave; see the file COPYING.  If not, write to the Free
 dnl Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
 dnl
-AC_REVISION($Revision: 1.44 $)dnl
+AC_REVISION($Revision: 1.45 $)dnl
 AC_PREREQ(1.8)dnl
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h kpathsea/c-auto.h)
@@ -72,6 +72,16 @@
 dnl Allow the user to experiment with dynamic linking using GNU dld.
 dnl
 AC_ENABLE(dld, use_dld=true, use_dld=false)dnl
+AC_SUBST(use_dld)dnl
+dnl
+dnl Allow compilation of smaller kernel.  This only works if some form
+dnl of dynamic linking is also supported and used.
+dnl
+AC_ENABLE(lite-kernel, lite_kernel=true, lite_kernel=false)dnl
+if $lite_kernel; then
+  AC_DEFINE(OCTAVE_LITE, 1)dnl
+fi
+AC_SUBST(lite_kernel)dnl
 dnl
 dnl some defaults
 dnl
@@ -169,7 +179,11 @@
   DYNAMIC_LD_OBJ='dynamic-ld.o'
   DLD_DIR=dld
   LIBDLD='../libdld.a'
-  LIBOCTDLD= # don't link them in if doing dynamic linking
+# don't link them in only if doing dynamic linking and small kernel
+# requested.
+  if $lite_kernel; then
+    LIBOCTDLD=
+  fi
   LD_STATIC_FLAG=-static
   AC_DEFINE(WITH_DLD, 1)dnl
 fi