diff configure.ac @ 19559:8d267cca249e gui-release

build: Don't build with g77. * bootstrap.conf: Remove bootstrap_epilogue () section. * configure.ac: Check for gfortran ahead of other Fortran compilers. Issue error message and stop configure if g77 is the only compiler found.
author Rik <rik@octave.org>
date Thu, 27 Nov 2014 18:54:22 -0800
parents 2d8728156ba4
children f550bf908f47
line wrap: on
line diff
--- a/configure.ac
+++ b/configure.ac
@@ -613,8 +613,17 @@
   FFLAGS="-O"
 fi
 
-## the F77 variable, if set, overrides AC_PROG_F77 automatically
-AC_PROG_F77
+## Prefer gfortran, but the user's F77 environment variable will override.
+AC_PROG_F77([gfortran])
+if test -z "$F77"; then
+  ## No gfortran found, search for any other installed compiler.
+  AC_PROG_F77
+fi
+if test "$F77" = g77; then
+  AC_MSG_ERROR([g77 is not a supported Fortran compiler.  Select another compiler by setting the environment variable F77 and re-running configure.])
+fi
+
+## Determine calling conventions for Fortran compiler
 AC_F77_LIBRARY_LDFLAGS
 AC_F77_DUMMY_MAIN
 AC_F77_WRAPPERS